View Issue Details

IDProjectCategoryView StatusLast Update
0000300Rocky-Linux-8corosyncpublic2022-11-17 10:26
ReporterMagnus Harlander Assigned To 
PriorityhighSeveritymajorReproducibilityalways
Status newResolutionopen 
PlatformServerOSRockyLinuxOS Version8.6
Summary0000300: rpm dependency problem - upgrade stuck
Descriptiondnf update has a problem with corosync installed because of a dependency problem with libknet1

root@s1 ~]# dnf update
Last metadata expiration check: 1:49:16 ago on Mon 19 Sep 2022 07:51:56 AM CEST.
Error:
 Problem: package libknet1-compress-bzip2-plugin-1.24-3.el8.x86_64 requires libknet1(x86-64) = 1.22-1.el8, but none of the providers can be installed
  - cannot install both libknet1-1.22-2.el8_6.x86_64 and libknet1-1.22-1.el8.x86_64
  - cannot install the best update candidate for package libknet1-compress-bzip2-plugin-1.24-3.el8.x86_64
  - cannot install the best update candidate for package libknet1-1.22-1.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
Steps To Reproducednf update
Additional Information[root@s1 ~]# hostnamectl
   Static hostname: s1.harlan.de
         Icon name: computer-desktop
           Chassis: desktop
        Machine ID: 3a0a6308630842ffad6b9bb8be4c7547
           Boot ID: 46422cfd8513485faa1866543365f6ac
  Operating System: Rocky Linux 8.6 (Green Obsidian)
       CPE OS Name: cpe:/o:rocky:rocky:8:GA
            Kernel: Linux 4.18.0-372.19.1.el8_6.x86_64
      Architecture: x86-64
[root@s1 ~]# uname -a
Linux s1.harlan.de 4.18.0-372.19.1.el8_6.x86_64 #1 SMP Tue Aug 2 16:19:42 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
[root@s1 ~]# dnf update
Last metadata expiration check: 1:57:37 ago on Mon 19 Sep 2022 07:51:56 AM CEST.
Error:
 Problem: package libknet1-compress-bzip2-plugin-1.24-3.el8.x86_64 requires libknet1(x86-64) = 1.22-1.el8, but none of the providers can be installed
  - cannot install both libknet1-1.22-2.el8_6.x86_64 and libknet1-1.22-1.el8.x86_64
  - cannot install the best update candidate for package libknet1-compress-bzip2-plugin-1.24-3.el8.x86_64
  - cannot install the best update candidate for package libknet1-1.22-1.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[root@s1 ~]# rpm -qa libknet1*
libknet1-1.22-1.el8.x86_64
libknet1-compress-lzma-plugin-1.24-3.el8.x86_64
libknet1-compress-plugins-all-1.24-3.el8.x86_64
libknet1-crypto-plugins-all-1.24-3.el8.x86_64
libknet1-compress-lzo2-plugin-1.24-3.el8.x86_64
libknet1-crypto-nss-plugin-1.24-3.el8.x86_64
libknet1-plugins-all-1.24-3.el8.x86_64
libknet1-crypto-openssl-plugin-1.24-3.el8.x86_64
libknet1-compress-bzip2-plugin-1.24-3.el8.x86_64
libknet1-compress-lz4-plugin-1.24-3.el8.x86_64
libknet1-compress-zlib-plugin-1.24-3.el8.x86_64
TagsNo tags attached.

Activities

Glittering Aspect983

Glittering Aspect983

2022-11-16 22:02

reporter   ~0001024

This is kind of a problem :(
Is this same as a https://bugzilla.redhat.com/show_bug.cgi?id=2128674
Glittering Aspect983

Glittering Aspect983

2022-11-16 22:10

reporter   ~0001025

This is kind of a problem :(
Is this same as a https://bugzilla.redhat.com/show_bug.cgi?id=2128674
Lukas Magauer

Lukas Magauer

2022-11-16 22:23

reporter   ~0001026

Hi Magnus and Glittering Aspect,
could you show us which repos you have enabled?
I'm trying to see which tries to match what right now.

Because I'm seeing a libknet1-compress-bzip2-plugin-1.24-3.1.el8.x86_64 in EPEL which requires libknet1(x86-64) = 1.22-2.el8_6 instead of what's showing up for you.
Lukas Magauer

Lukas Magauer

2022-11-16 22:33

reporter   ~0001027

The thing that could happen right now is, that you will have to use --nobest, because in PowerTools there is now libknet1-1.24-2.el8.x86_64, which is later than what is required by the EPEL package.
Unfortunately this will also only work for upgrades, new installations will have to wait until the package gets upgraded in EPEL, as with the release of 8.7, the old packages got moved to an (for now semi-) archived tree (and has a few more package dependencies down the line like glibc if I see that correctly)
Glittering Aspect983

Glittering Aspect983

2022-11-17 10:26

reporter   ~0001057

# dnf repolist
repo id repo name
appstream Rocky Linux 8 - AppStream
baseos Rocky Linux 8 - BaseOS
epel Extra Packages for Enterprise Linux 8 - x86_64
extras Rocky Linux 8 - Extras
ha Rocky Linux 8 - HighAvailability

I think that problem is in enabled epel repo.
In epel exist libknet1-compress-zlib-plugin.x86_64 1.24-3.1.el8 and that is causing a problem.
Last metadata expiration check: 1:09:12 ago on Wed 16 Nov 2022 06:56:09 PM EST.
Error:
 Problem 1: cannot install the best update candidate for package libknet1-compress-bzip2-plugin-1.24-2.el8.x86_64
  - nothing provides libknet1(x86-64) = 1.22-2.el8_6 needed by libknet1-compress-bzip2-plugin-1.24-3.1.el8.x86_64
 Problem 2: cannot install the best update candidate for package libknet1-compress-lz4-plugin-1.24-2.el8.x86_64
  - nothing provides libknet1(x86-64) = 1.22-2.el8_6 needed by libknet1-compress-lz4-plugin-1.24-3.1.el8.x86_64
 Problem 3: cannot install the best update candidate for package libknet1-compress-lzma-plugin-1.24-2.el8.x86_64
  - nothing provides libknet1(x86-64) = 1.22-2.el8_6 needed by libknet1-compress-lzma-plugin-1.24-3.1.el8.x86_64
 Problem 4: cannot install the best update candidate for package libknet1-compress-lzo2-plugin-1.24-2.el8.x86_64
  - nothing provides libknet1(x86-64) = 1.22-2.el8_6 needed by libknet1-compress-lzo2-plugin-1.24-3.1.el8.x86_64
 Problem 5: cannot install the best update candidate for package libknet1-compress-zlib-plugin-1.24-2.el8.x86_64
  - nothing provides libknet1(x86-64) = 1.22-2.el8_6 needed by libknet1-compress-zlib-plugin-1.24-3.1.el8.x86_64
 Problem 6: cannot install the best update candidate for package libknet1-crypto-nss-plugin-1.24-2.el8.x86_64
  - nothing provides libknet1(x86-64) = 1.22-2.el8_6 needed by libknet1-crypto-nss-plugin-1.24-3.1.el8.x86_64
 Problem 7: cannot install the best update candidate for package libknet1-crypto-openssl-plugin-1.24-2.el8.x86_64
  - nothing provides libknet1(x86-64) = 1.22-2.el8_6 needed by libknet1-crypto-openssl-plugin-1.24-3.1.el8.x86_64
 Problem 8: package libknet1-crypto-plugins-all-1.24-3.1.el8.x86_64 requires libknet1-crypto-openssl-plugin(x86-64) = 1.24-3.1.el8, but none of the providers can be installed
  - cannot install the best update candidate for package libknet1-crypto-plugins-all-1.24-2.el8.x86_64
  - nothing provides libknet1(x86-64) = 1.22-2.el8_6 needed by libknet1-crypto-openssl-plugin-1.24-3.1.el8.x86_64
 Problem 9: package libknet1-compress-plugins-all-1.24-3.1.el8.x86_64 requires libknet1-compress-zlib-plugin(x86-64) = 1.24-3.1.el8, but none of the providers can be installed
  - cannot install the best update candidate for package libknet1-compress-plugins-all-1.24-2.el8.x86_64
  - nothing provides libknet1(x86-64) = 1.22-2.el8_6 needed by libknet1-compress-zlib-plugin-1.24-3.1.el8.x86_64
 Problem 10: package libknet1-plugins-all-1.24-3.1.el8.x86_64 requires libknet1-compress-plugins-all(x86-64) = 1.24-3.1.el8, but none of the providers can be installed
  - package libknet1-compress-plugins-all-1.24-3.1.el8.x86_64 requires libknet1-compress-zlib-plugin(x86-64) = 1.24-3.1.el8, but none of the providers can be installed
  - cannot install the best update candidate for package libknet1-plugins-all-1.24-2.el8.x86_64
  - nothing provides libknet1(x86-64) = 1.22-2.el8_6 needed by libknet1-compress-zlib-plugin-1.24-3.1.el8.x86_64

Issue History

Date Modified Username Field Change
2022-09-19 08:02 Magnus Harlander New Issue
2022-11-16 22:02 Glittering Aspect983 Note Added: 0001024
2022-11-16 22:10 Glittering Aspect983 Note Added: 0001025
2022-11-16 22:23 Lukas Magauer Note Added: 0001026
2022-11-16 22:33 Lukas Magauer Note Added: 0001027
2022-11-17 10:26 Glittering Aspect983 Note Added: 0001057