View Issue Details

IDProjectCategoryView StatusLast Update
0000300Rocky-Linux-8corosyncpublic2022-09-19 08:02
ReporterMagnus Harlander Assigned To 
PriorityhighSeveritymajorReproducibilityalways
Status newResolutionopen 
PlatformServerOSRockyLinuxOS Version8.6
Summary0000300: rpm dependency problem - upgrade stuck
Descriptiondnf update has a problem with corosync installed because of a dependency problem with libknet1

root@s1 ~]# dnf update
Last metadata expiration check: 1:49:16 ago on Mon 19 Sep 2022 07:51:56 AM CEST.
Error:
 Problem: package libknet1-compress-bzip2-plugin-1.24-3.el8.x86_64 requires libknet1(x86-64) = 1.22-1.el8, but none of the providers can be installed
  - cannot install both libknet1-1.22-2.el8_6.x86_64 and libknet1-1.22-1.el8.x86_64
  - cannot install the best update candidate for package libknet1-compress-bzip2-plugin-1.24-3.el8.x86_64
  - cannot install the best update candidate for package libknet1-1.22-1.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
Steps To Reproducednf update
Additional Information[root@s1 ~]# hostnamectl
   Static hostname: s1.harlan.de
         Icon name: computer-desktop
           Chassis: desktop
        Machine ID: 3a0a6308630842ffad6b9bb8be4c7547
           Boot ID: 46422cfd8513485faa1866543365f6ac
  Operating System: Rocky Linux 8.6 (Green Obsidian)
       CPE OS Name: cpe:/o:rocky:rocky:8:GA
            Kernel: Linux 4.18.0-372.19.1.el8_6.x86_64
      Architecture: x86-64
[root@s1 ~]# uname -a
Linux s1.harlan.de 4.18.0-372.19.1.el8_6.x86_64 #1 SMP Tue Aug 2 16:19:42 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
[root@s1 ~]# dnf update
Last metadata expiration check: 1:57:37 ago on Mon 19 Sep 2022 07:51:56 AM CEST.
Error:
 Problem: package libknet1-compress-bzip2-plugin-1.24-3.el8.x86_64 requires libknet1(x86-64) = 1.22-1.el8, but none of the providers can be installed
  - cannot install both libknet1-1.22-2.el8_6.x86_64 and libknet1-1.22-1.el8.x86_64
  - cannot install the best update candidate for package libknet1-compress-bzip2-plugin-1.24-3.el8.x86_64
  - cannot install the best update candidate for package libknet1-1.22-1.el8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
[root@s1 ~]# rpm -qa libknet1*
libknet1-1.22-1.el8.x86_64
libknet1-compress-lzma-plugin-1.24-3.el8.x86_64
libknet1-compress-plugins-all-1.24-3.el8.x86_64
libknet1-crypto-plugins-all-1.24-3.el8.x86_64
libknet1-compress-lzo2-plugin-1.24-3.el8.x86_64
libknet1-crypto-nss-plugin-1.24-3.el8.x86_64
libknet1-plugins-all-1.24-3.el8.x86_64
libknet1-crypto-openssl-plugin-1.24-3.el8.x86_64
libknet1-compress-bzip2-plugin-1.24-3.el8.x86_64
libknet1-compress-lz4-plugin-1.24-3.el8.x86_64
libknet1-compress-zlib-plugin-1.24-3.el8.x86_64
TagsNo tags attached.

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2022-09-19 08:02 Magnus Harlander New Issue