View Issue Details

IDProjectCategoryView StatusLast Update
0000171Rocky-Linux-8Installerpublic2022-08-05 12:55
ReporterAndres Tarallo Assigned To 
PriorityhighSeveritymajorReproducibilityhave not tried
Status newResolutionopen 
Platformx86_64OSRocky Linux OS Version8.6
Summary0000171: Network Card Goes Down after a few minutes ... Misconfigured on Install
DescriptionDid a fresh install from DVD, Configured network card on the Installer. Filled in the necessary parameters in Network configuration (IP Address, mask, DNS...).

After booting I logged into the system via SSH. After a few minutes the session freezes. I logged from the console and noticed the network interface was down. Tried to bring it up from nmtui, without success.

After a few times this happend I went to run "journalctl -xe". I've noticed messages from DHCPCD. Then went again to nmtui. I've noticed that the network card was configured in "automatic" but had the parameters of manual configuration.
Steps To ReproduceDo the install. Configure Network card from the installer. keep the configuration in automatic (DHCP) and fill in the parameters needed for manual configuration.
Additional InformationNeed to check this on RHEL 8.6.
TagsNo tags attached.


Andres Tarallo

Andres Tarallo

2022-08-04 16:42

reporter   ~0000324

I continued investigating. Today I had a freshly installed RockyLinux 8.6, network wasn't configured during install. I've fired nmtui and did manual configuration. On purpose I've keep automatic and provided manual configuration parameters (IP/Mask, default gateway and DNS). Got the same behaviour.

Did screenshots that attached to this note. I'm now thinking that this might be a network-manager Issue, not an Installer bug.
Screenshot_20220804_130436.png (145,571 bytes)   
Screenshot_20220804_130436.png (145,571 bytes)   
Screenshot_20220804_123128.png (101,526 bytes)   
Screenshot_20220804_123128.png (101,526 bytes)   
Louis Abel

Louis Abel

2022-08-05 02:35

administrator   ~0000326

Thank you for the report.

This doesn't appear to be a bug and is normal behavior with network manager (where the configuration stays "automatic" despite filling in static data). If you are configuring a static address, you generally should set the method to manual. On the command line for example, you would use `nmcli con mod <interface> ipv4.method manual` to ensure that this is the case. Otherwise, auto is the default. This is the case whether you're doing it from nmcli, nmtui, or the installer.
Andres Tarallo

Andres Tarallo

2022-08-05 12:55

reporter   ~0000327

I don't understand this as a bug too, mostly misfeature. I wouldn't realize of this if I did it in a network with an active DHCP server.

I think that at least the graphicall installer shouldn't let you fill manual values, when you choose automatic.

It took me several minutes to find out what's going on.

Issue History

Date Modified Username Field Change
2022-08-02 21:33 Andres Tarallo New Issue
2022-08-04 16:42 Andres Tarallo Note Added: 0000324
2022-08-04 16:42 Andres Tarallo File Added: Screenshot_20220804_130436.png
2022-08-04 16:42 Andres Tarallo File Added: Screenshot_20220804_123128.png
2022-08-05 02:35 Louis Abel Note Added: 0000326
2022-08-05 12:55 Andres Tarallo Note Added: 0000327