View Issue Details

IDProjectCategoryView StatusLast Update
0000200Rocky-Linux-9Packagespublic2022-08-23 19:42
ReporterWinnie Yue Assigned ToLouis Abel  
PrioritylowSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Fixed in Version9.0 
Summary0000200: Request a correct OVT 11.3.5 release
DescriptionPlease refer to the attached screenshot, it is about guestID info reported from OVT for Rocky Linux 9.0 on ESXi 7.0U3. The last three rows are as expected since the kernel version of Rocky Linux 9.x is 5.14.

From vmware/open-vm-tools#513, it seems that Rocky Linux put proposed changes for GuestID.
These changes (https://github.com/vmware/open-vm-tools/pull/513/files) modified:
guest_os.h
guest_os_tables.h
hostinfoPosix.c

Were these changes included in your 11.3.5 open-vm-tools packages? If so, could you please remove these changes and correct to the 11.3.5 OVT packages?

Just a reminder, please do not have any alterations in a 12.0.x OVT release or the upcoming OVT. Thanks a lot.
TagsNo tags attached.

Activities

Winnie Yue

Winnie Yue

2022-08-18 08:10

reporter  

RockyLinux_GuestID.png (171,116 bytes)   
RockyLinux_GuestID.png (171,116 bytes)   
Winnie Yue

Winnie Yue

2022-08-18 08:42

reporter   ~0000364

Below screenshot is for Rocky Linux 8.6 which also integrates 11.3.5. GuestID should always be other4xLinux64Guest since its kernel version is 4.18.
image.png (5,079 bytes)   
image.png (5,079 bytes)   
Louis Abel

Louis Abel

2022-08-18 09:16

administrator   ~0000365

Last edited: 2022-08-18 09:53

The changes that were made were for community members to properly utilize vRA automation in prior Rocky Linux 8 versions (starting with 8.3). The incorrect hardware level being presented in vSphere is unfortunately a side effect of the changes made. With that being said, if you can provide logs and other data that shows that using an unpatched open-vm-tools will allow vRealize Automation to work without any issues, we will revert the patch. Setting to needinfo for now.

Please note that changes will not be made during 12.X by request of vmware engineers and based on the change log for 12.X. Beyond this, we will be waiting for your feedback (this includes logs, not just screenshots) that vRA will operate on an unpatched open-vm-tools package for both Rocky Linux 8 and Rocky Linux 9.
Louis Abel

Louis Abel

2022-08-23 19:42

administrator   ~0000465

Resolved in:

open-vm-tools-11.3.5-1.el8.0.2
open-vm-tools-11.3.5-1.el9.0.2

Issue History

Date Modified Username Field Change
2022-08-18 08:10 Winnie Yue New Issue
2022-08-18 08:10 Winnie Yue File Added: RockyLinux_GuestID.png
2022-08-18 08:42 Winnie Yue Note Added: 0000364
2022-08-18 08:42 Winnie Yue File Added: Screen Shot 2022-08-18 at 16.40.42.png
2022-08-18 08:42 Winnie Yue File Added: image.png
2022-08-18 09:14 Louis Abel Priority high => low
2022-08-18 09:16 Louis Abel Assigned To => Louis Abel
2022-08-18 09:16 Louis Abel Status new => needinfo
2022-08-18 09:16 Louis Abel Note Added: 0000365
2022-08-18 09:53 Louis Abel Note Edited: 0000365
2022-08-23 19:42 Louis Abel Status needinfo => resolved
2022-08-23 19:42 Louis Abel Resolution open => fixed
2022-08-23 19:42 Louis Abel Fixed in Version => 9.0
2022-08-23 19:42 Louis Abel Note Added: 0000465